SegwayChat
Home . Old Gallery

Go Back   SegwayChat > Segway Forums > New Member Introductions

Notices

New Member Introductions Welcome to our community! Come in and introduce yourself to other members!

Old 07-28-2020, 02:58 PM   #1
jabackes
Junior Member
jabackes is on a distinguished road
 
jabackes's Avatar
 
Join Date: Aug 2009
Location: Hermiston Oregon
Posts: 31
5 yr Member Segway Polo Player
Talking Quick Reintroduction!

Hey All!

Its been a minute, that's for sure. Finally my wife and I have gotten into a position to be able to get ourselves our very own Segways. We're hopefully (nearly 99% likely) taking ownership of a set of Segways from a seller in Spokane . Our seller is the second owner and has both an i2 and an x2 for sale and we were able to talk up a great deal for them both. Sadly we only get one set of batteries between the two, but all accessories and even the "dead" batteries are included in the sale. We pick up on Friday this week if all goes well and I'll be starting Polo try-outs for the Tri-Cities next week Well... if we can get some signups! So excited everybody! It's finally come true!
__________________
˙ɹǝʌo ǝɯ uɹnʇ 'sıɥʇ pɐǝɹ uɐɔ noʎ ɟı
jabackes is offline   Reply With Quote
Old 08-05-2020, 10:37 PM   #2
bottleworks
Junior Member
bottleworks is on a distinguished road
 
Join Date: Feb 2012
Location: North Carolina
Posts: 28
5 yr Member
Default

I hope you got them. I just finished rebuilding 4 batteries for our Segways. If you need any help with rebuilding, let me know.
__________________
2004 Segway i167 w/ i180 Wheels
2005 Segway i180
bottleworks is offline   Reply With Quote
Old 08-06-2020, 04:31 PM   #3
jabackes
Junior Member
jabackes is on a distinguished road
 
jabackes's Avatar
 
Join Date: Aug 2009
Location: Hermiston Oregon
Posts: 31
5 yr Member Segway Polo Player
Default

we did get them! X2 and i2 with less than three hundred miles combined! they're in great, but dirty condition and we've already put over 20 miles more on the x2. I'm looking into getting a bench supply to try and revive the dead cell batteries but the two that came with the sale work great so far. they were purchased in June and so far have handeled the x2 and i2 perfectly (swapping between the two) I got some spare lithium coin cells so all the InfoKeys are tested as working and the only other "dead" cell is one of the headlights in the sale has a dead pack (the lights both work great on one pack, but the other doesn't seem to be taking a charge.
__________________
˙ɹǝʌo ǝɯ uɹnʇ 'sıɥʇ pɐǝɹ uɐɔ noʎ ɟı
jabackes is offline   Reply With Quote
Reply

Tags
i2, new to me, polo, x2


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:29 AM.
Copyright 2002-2020 SegwayChat.org.
All rights reserved. Not affiliated with Segway Inc.

FreshBlue vBulletin skin by
VayaDesign
Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SegwayChat Archive