SegwayChat
Home . Old Gallery

Go Back   SegwayChat > Segway Forums > Segway General Discussion

Notices

Segway General Discussion General discussion related to any model of Segways, miniPROs, or Ninebots. Please do not post non-Segway technology posts here; use the technology forum instead.

Old 08-10-2022, 04:05 PM   #1
jdiepold
New Member
jdiepold is on a distinguished road
 
Join Date: Aug 2022
Location: NJ
Posts: 2
Default PT Battery Screws

Hi, I needs some help.

I am in the process of installing new batteries in my PT. The top battery screws came out just fine. The bottom battery screws (all 4) will not come out. I fear they are striped. I would greatly appreciate recommendations about getting these screws out.

Thank you.
jdiepold is offline   Reply With Quote
Old 08-12-2022, 01:10 AM   #2
truck
Member
truck is on a distinguished road
 
truck's Avatar
 
Join Date: Aug 2017
Location: Breinigsville PA
Posts: 133
5 yr Member
Default

The screws don't unscrew very far. Is it possible they are fully unscrewed from the threads? Can you wiggle the battery? If you can, the battery is ready to lift off.
truck is offline   Reply With Quote
Old 08-16-2022, 09:44 PM   #3
jdiepold
New Member
jdiepold is on a distinguished road
 
Join Date: Aug 2022
Location: NJ
Posts: 2
Default

Thank you. There was no wiggle.I took the PT to a machine shop and they got the screws out, which had to be drilled out, and new sc news put in.

The new batteries are in, but it still won't charge. Only the top green light flashes. Am I missing something? I don't know where to go from here to get the new batteries charged.
jdiepold is offline   Reply With Quote
Old 08-18-2022, 08:44 AM   #4
dgbint
Member
dgbint will become famous soon enoughdgbint will become famous soon enough
 
dgbint's Avatar
 
Join Date: Apr 2003
Location: Melbourne, VIC, Australia.
Posts: 983
5 yr Member HT/PT Owner
Default

You may have a faulty battery or a faulty charger.

To work out which it is, swap the front and rear batteries.
If the fault stays in the same place, it is a charger fault.
If the fault moves, it is a battery fault.

Good luck
Michael
dgbint is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:09 PM.
Copyright 2002-2022 SegwayChat.org.
All rights reserved. Not affiliated with Segway Inc.

FreshBlue vBulletin skin by
VayaDesign
Powered by vBulletin
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
SegwayChat Archive