SegwayChat
Home . Old Gallery

Go Back   SegwayChat > Segway Forums > Segway General Discussion > Reference Information & How-To's

Notices

Reference Information & How-To's Valuable reference information, stolen Segway reporting, how-to's, error codes & more.

Old 03-21-2021, 08:02 PM   #1
wilhendrix
First Timer
wilhendrix is on a distinguished road
 
Join Date: Mar 2021
Location: Flagstaff, Arizona
Posts: 1
Default X2 with jerky steering until it's been ridden about a mile

My X2 (with 4000 miles) has started to sort of jerk when steering left or right. It feels like there is some slop in the connection between the lean steer and base. I took the stem off and it seems fine. Interesting part is the problem seems to go away after about a mile of riding. That makes me think it's electronic, not a connection issue. Have had two X2 (15 years) and have about 8000 miles total. I can't walk very well and the X2 is a great substitute for legs.
wilhendrix is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:30 AM.
Copyright 2002-2020 SegwayChat.org.
All rights reserved. Not affiliated with Segway Inc.

FreshBlue vBulletin skin by
VayaDesign
Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
SegwayChat Archive