SegwayChat
Home . Photos . Old Gallery

Go Back   SegwayChat > Segway Forums > Segway General Discussion

Notices

Segway General Discussion General discussion related to any model of Segways, miniPROs, or Ninebots. Please do not post non-Segway technology posts here; use the technology forum instead.

Old 08-13-2017, 05:02 PM   #1
segsurfer
Senior Member
segsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to all
 
segsurfer's Avatar
 
Join Date: Oct 2007
Location: Harrisonburg, VA
Posts: 1,356
5 yr Member HT/PT Owner Segway Polo Player SegwayFest Attendee
Default Well it finally happened...

After almost a decade of service, my i2 called it quits, and tossed an e107 error. I am in the process of trying to procure another one, but damn, you don't realize just how much you depend on these units until they falter.
__________________
Life is not a Roadrunner cartoon, and you are not the Roadrunner!.

To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
segsurfer is offline   Reply With Quote
Old 08-13-2017, 05:30 PM   #2
airdale
Member
airdale is on a distinguished road
 
Join Date: Jul 2013
Location: Arizona
Posts: 436
3 yr Member
Default

Quote:
Originally Posted by segsurfer View Post
After almost a decade of service, my i2 called it quits, and tossed an e107 error. I am in the process of trying to procure another one, but damn, you don't realize just how much you depend on these units until they falter.
Yes, my X2 has been down for 9 months.....only close dealer 100 miles away.....Would be nice if Segway had a better idea of what service is...Hope you get up and gliding asap!
airdale is offline   Reply With Quote
Old 08-13-2017, 06:01 PM   #3
segsurfer
Senior Member
segsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to allsegsurfer is a name known to all
 
segsurfer's Avatar
 
Join Date: Oct 2007
Location: Harrisonburg, VA
Posts: 1,356
5 yr Member HT/PT Owner Segway Polo Player SegwayFest Attendee
Default

Quote:
Originally Posted by airdale View Post
Yes, my X2 has been down for 9 months.....only close dealer 100 miles away.....Would be nice if Segway had a better idea of what service is...Hope you get up and gliding asap!
It's my understanding that the mothership has been pulling back repairs to the mothership by way of increasing the expense to dealers for repair equipment Irritating to put it mildly, really screws over disabled riders.
__________________
Life is not a Roadrunner cartoon, and you are not the Roadrunner!.

To view links or images in signatures your post count must be 5 or greater. You currently have 0 posts.
segsurfer is offline   Reply With Quote
Old 08-13-2017, 07:30 PM   #4
dale@thecoys.net
Member
dale@thecoys.net will become famous soon enough
 
dale@thecoys.net's Avatar
 
Join Date: Dec 2005
Location: Lee's Summit, MO, USA
Posts: 1,167
5 yr Member
Default

In April, my grandson was riding one of our XTs. It gave the shutdown warning, he stepped off, and it did shut down. Trying to restart it gave the usual red warning when the key was applied. Note: it was running fine before the shutdown.

I took it to the local place that Segway says is a dealer - http://mmtran.com/

Of course, the local branch office doesn't actually have anybody who knows anything, so they sent it to their main office. That office tried, but couldn't figure out what was wrong, so they sent it to Segway.

I just got (in August, by telephone) a repair estimate of over $1,800. They said they needed to replace 2 wiring harnesses, a circuit board, some other things, and the handlebar. Note: it was working fine just before it shut down.

I told them "no, just send it back". I wonder what shape it will be in when (if) it returns.
dale@thecoys.net is offline   Reply With Quote
Old 08-14-2017, 11:32 AM   #5
Seginaway
Member
Seginaway will become famous soon enough
 
Seginaway's Avatar
 
Join Date: Jan 2008
Location: Metropolis of Harleysville, PA
Posts: 236
5 yr Member
Default Segway Inc. repaired my 9 year old . . .

One day Trigger worked, the next day it didn't. No advance notice, problems or signs of trouble. It just wouldn't turn on.

Segway, Inc. response:
Unit appears to have been opened by unauthorized persons. Upon initial inspection; fasteners were missing, markings on components, antenna broken off of Radio Board, and BSA-A connector was broken. The BSA and Radio Board (UI Console PCB) require replacement due to damage/mishandling. Fault Logs indicate Motor Voltage Consistency Fault local to the A side CU and Left side Motor. Upon inspection Left side Motor was noticed to be damaged; replacement is required. Console housing is cracked and requires replacement to prevent water ingress. Console cover and gasket will be updated to the current revision under warranty. Ferrites were missing; will be replaced under warranty. Gearbox will be replaced under warranty due to RTV gasket.

Segway Inc. repaired my 9 year old X2 (now 11), new motor, trans (left side) and numerous other issues for a total cost of ~$1,500 processed through my dealer. Dealer purchased and sent me a Segway box (~$50), I removed wheels, handle bar and sent the base directly to NH. Got it back about three (3) weeks later and everything was fine. Dealer, Lehigh Valley Segway, facilitated the transaction and it went quite well.

45 days later the same issue arose (EO47 - but opposite "B" side). Contacted my dealer and sent the machine back to NH. No additional cost but they replaced the other side (engine/trans).

Now that is service with a smile for a 10,000 mile / 9 year old machine. As a result, I wouldn't hesitate to request a factory repair (pay the S&H & diagnostic costs) as most dealers are not going to do a strip down and total repair. Just can't see how bad it is to use NH, pay $1,500 and get, essentially, a brand new machine. I suffered Glide Withdrawal for the weeks I didn't have Trigger, but the new updated Trigger should provide another 10 years of some great Gliding.

Still amazed as it looks like I pretty much got a brand new machine after 9 years of use for $1,500 and along with some rebuilt MTO batteries, it has been 2 yrs. and 1,000 miles later and all is going well. Just had to put up with the down time.

Last edited by Seginaway; 08-14-2017 at 02:41 PM.. Reason: clarification of when initial shutdown happened & repair
Seginaway is offline   Reply With Quote
Old 08-14-2017, 12:11 PM   #6
Pescador12
Member
Pescador12 is on a distinguished road
 
Join Date: Dec 2016
Location: USA
Posts: 101
Default

Quote:
Originally Posted by dale@thecoys.net View Post
In April, my grandson was riding one of our XTs. It gave the shutdown warning, he stepped off, and it did shut down. Trying to restart it gave the usual red warning when the key was applied. Note: it was running fine before the shutdown.

I took it to the local place that Segway says is a dealer - http://mmtran.com/

Of course, the local branch office doesn't actually have anybody who knows anything, so they sent it to their main office. That office tried, but couldn't figure out what was wrong, so they sent it to Segway.

I just got (in August, by telephone) a repair estimate of over $1,800. They said they needed to replace 2 wiring harnesses, a circuit board, some other things, and the handlebar. Note: it was working fine just before it shut down.

I told them "no, just send it back". I wonder what shape it will be in when (if) it returns.
That sounds like a list of possible parts that could cause the problem. For instance, a list of everything in the steering control path. Would like to see how they troubleshoot.

Do they replace a harness with a mockup part to see if that fixes it? Then install a new harness. Or just shotgun it as there is no chance of a repeat write-up since everything was replaced? Unless they replace everything on the wrong wheel as in the above example
Pescador12 is offline   Reply With Quote
Old 09-22-2017, 04:38 PM   #7
dale@thecoys.net
Member
dale@thecoys.net will become famous soon enough
 
dale@thecoys.net's Avatar
 
Join Date: Dec 2005
Location: Lee's Summit, MO, USA
Posts: 1,167
5 yr Member
Default

Quote:
Originally Posted by dale@thecoys.net View Post
In April, my grandson was riding one of our XTs. It gave the shutdown warning, he stepped off, and it did shut down. Trying to restart it gave the usual red warning when the key was applied. Note: it was running fine before the shutdown.

I took it to the local place that Segway says is a dealer - http://mmtran.com/

Of course, the local branch office doesn't actually have anybody who knows anything, so they sent it to their main office. That office tried, but couldn't figure out what was wrong, so they sent it to Segway.

I just got (in August, by telephone) a repair estimate of over $1,800. They said they needed to replace 2 wiring harnesses, a circuit board, some other things, and the handlebar. Note: it was working fine just before it shut down.

I told them "no, just send it back". I wonder what shape it will be in when (if) it returns.
For completeness, here is the diagnosis:
"The unknown platform fault issue reported by the customer was repeatable and was diagnosed. Diagnostic testing revealed that the A side lot indicates A: Initialization: Motor rive Hall Fault, Actuator Degraded Fault. B side log indicates: Initialization CU BCU Bus Fualt, Motor Dirve Hall Fault. A side CU was damaged during the testing, will replace under warranty for this reason. Chassis was damaged during testing, will replace under warranty for that reason. Testing reveiled that both An& B side CU-Motor harnesses require replacement as indicated by faults. Checked CS and CSB cables and connectors: FAIL: Cables damaged: Replacement Required."

The $1,817.95 cost for repairs breaks down as follows (not including the replacement of the Controller Unit Board and Chassis, damaged during testing).

$315.00 x 2 for the CU-Motor Harness
$989.95 for the Handlebar
$198 for shipping
dale@thecoys.net is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:33 AM.
Copyright 2002-2017 SegwayChat.org.
All rights reserved. Not affiliated with Segway Inc.

FreshBlue vBulletin skin by
VayaDesign
Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SegwayChat Archive